Bass+Guitar amp=uhh oh....

Problems with equipment? Problem fitting them into the above forums? Post 'em here.

Bass+Guitar amp=uhh oh....

Postby gjbrocker » Sat Aug 21, 2010 4:47 am

So my friends and I were setting up to jam today and realized we lacked a bass rig for our bassist. We decided to try the bass through a Carvin 2x12 something guitar amp just so we could get enough to play to (it didn't take much...it shakes the house at 2). However after a while, we started to smell something like burning wood so we immediately turned off the amp. When we tried to turn it back on, we got nothing at all.

Now i know i was a stupid idea so we can skip the ridicule...but i could really use some help figuring out just what is wrong with this amp. Answers?
gjbrocker
Regular
 
Posts: 16
Joined: Thu Feb 07, 2008 3:05 am

Re: Bass+Guitar amp=uhh oh....

Postby zhyla » Sat Aug 21, 2010 7:55 pm

You'd think you'd blow the speakers before you damage the amp itself. Could be tubes, could be transformers.
User avatar
zhyla
Site Admin
 
Posts: 947
Joined: Thu Mar 09, 2006 2:43 pm

Re: Bass+Guitar amp=uhh oh....

Postby maxx england » Sat Aug 21, 2010 10:51 pm

Don't know, but the first thing I'd check, as a total electronic "durr", is that all the soldered connections are still soldered.
User avatar
maxx england
Contributor
Contributor
 
Posts: 3944
Joined: Thu Jan 01, 1970 12:00 am
Location: Birmingham UK


Return to Equipment Blues

Who is online

Users browsing this forum: No registered users and 4 guests

cron